Trouble with WDM Realtek digital output

The Virtual Audio Mixer discussions and support...
tox
Posts: 6
Joined: Thu Oct 06, 2016 4:43 pm

Re: Trouble with WDM Realtek digital output

Postby tox » Sun Feb 12, 2017 5:40 pm

Yes, the problem only appears to affect Dolby Digital Live. On a side note, Dolby DIgital Live and DTS Connect are once again broken in Windows 10 Insider Builds. I'm now running build 14986 and it doesn't work no matter whether it's direct from the Realtek driver or via Voicemeeter.

Microsoft really need to get their act together when it comes to multichannel / multi device audio.

CaptaPraelium
Posts: 10
Joined: Mon Oct 17, 2016 4:31 am

Re: Trouble with WDM Realtek digital output

Postby CaptaPraelium » Thu Feb 16, 2017 2:52 pm

Vincent Burel wrote:the problem seems to concern only this Realtek Optical output in multichannel mode and WDM interface...
we simply have to reproduce the problem here to correct it...
what is connected to your optical link : an AV-amplifier ?


I agree, it seems specific to multichannel mode (dolby digital specifically) and WDM and realtek cards.
I have a headset base-unit connected to the PC via optical cable. I've tried a hifi receiver and had the same behaviour.
I have lots of spare time if you want any testing done consider me available.

Vincent Burel
Site Admin
Posts: 375
Joined: Sun Jan 17, 2010 12:01 pm

Re: Trouble with WDM Realtek digital output

Postby Vincent Burel » Fri Feb 17, 2017 7:52 am

thanks for your help... maybe you could try to reproduce the problem on other application (VLC ?) using WASAPI to output audio to this optical device in multichannel mode and let me know if it works or not...

CaptaPraelium
Posts: 10
Joined: Mon Oct 17, 2016 4:31 am

Re: Trouble with WDM Realtek digital output

Postby CaptaPraelium » Fri Feb 17, 2017 9:12 am

Thank you for helping us!
Good idea. I had not seen this problem anywhere else but after a few minutes trying different configurations of VLC, I was able to get the distortion to occur. It only gives distortion when I select "Windows Multimedia Device output" as the 'Output module', and select my realtek optical output as the default in windows. Using this configuration, if I view the module list, I can see 'generic"wasapi"' as a loaded module. Other configurations which do not distort, do not show this module... So I guess I am using wasapi when the distortion occurs, and no distortion when I am not using wasapi.
I hope this helps. Please let me know if there's anything else I can try for you.

Vincent Burel
Site Admin
Posts: 375
Joined: Sun Jan 17, 2010 12:01 pm

Re: Trouble with WDM Realtek digital output

Postby Vincent Burel » Fri Feb 17, 2017 9:48 am

it's maybe a problem more related to Realtek driver or Micrsoft WASAPI ...
i've posted the question on 'wdmaudiodev@freelists.org' ...

CaptaPraelium
Posts: 10
Joined: Mon Oct 17, 2016 4:31 am

Re: Trouble with WDM Realtek digital output

Postby CaptaPraelium » Fri Feb 17, 2017 1:10 pm

This may be interesting: Reaper seems to work with this card and driver in WASAPI mode. Exclusive mode throws an error:

Code: Select all

There was an error opening the audio hardware:

WASAPI error: could not find output device format

But shared mode works fine. No distortion, no long/odd length buffers
HTH!
By the way, I stumbled across ASIO drivers for these cards while testing, if anyone's interested I could send a link.

Vincent Burel
Site Admin
Posts: 375
Joined: Sun Jan 17, 2010 12:01 pm

Re: Trouble with WDM Realtek digital output

Postby Vincent Burel » Fri Feb 17, 2017 8:24 pm

ha, this could mean that it is a problem on format negotiation or share mode management...
i will take a look soon...


Return to “Voicemeeter”

Who is online

Users browsing this forum: No registered users and 2 guests